How to troubleshoot backup or restore jobs that fail with "an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent"
Details:
This warning
can be generated in the job log when backing up a computer if no Remote Agent is
installed. Backup Exec requires the Remote Agent to be installed and running on
these machines in order to fully protect them. No license is required to install
the Remote Agent on a Windows 2000 or XP Professional computer.
The Remote
Agent can either be "push installed" from the Backup Exec server or
alternatively be installed locally on each Windows computer. Please refer to the
Related Documents section below on how to install the Remote Agent.
Error on
Local/Remote server:
With Backup
Exec for Windows Servers (BEWS) 9.x and above, the Remote Agent is
also used on the Backup Exec media server for local backups. This is by
design, enhances backup performance and therefore, this error could also occurs
on the local server as well.
"The
resource could not be backed up because an error occurred while connecting to
the Backup Exec for Windows Servers Remote Agent. Make sure that the Remote
Agent is running on the target computer"
Cause(s):
1. This error
may occur due to a corrupt installation of the Remote Agent on the local system
during Backup Exec installation.
2. The reason
for the backup job to fail could be the 'Backup Exec Remote Agent for Windows
Server' service running on the Backup Exec media server terminates or is stopped
during the backup of the remote system.
3. All the
Backup Exec Services on the media server are logging on and running with Local
System Account (LSA). The Backup Exec Services on the media server, by default,
all startup with the user account specified during the installation, with the
exception of the Remote Agent Service. If the services are all running under the
LSA, this change was made manually by an administrator after the initial
installation.
To further
diagnose and possibly resolve the issue, follow the steps below:
1. Make sure
Backup Exec Service Account is a member of local administrator and Domain Admins
group as well.
2. Ensure that
all the services (except for the Remote Agent which starts as the Local System
Account) are started using this account information.
3. Ensure that
TCP Port 10000 is not in use by any other application. For details please
refer to the TechNote ID:256312 in Related Documents section.
4. Confirm the
local area connection is at the top of the Network Connections list on both
servers (Network Connections > Advanced Settings > Adapters and
Bindings)
5. If the Media
Server has two NIC (Network Interface Card) cards, set the specific card for the
local backups as per the steps given below:
a.
In the Backup Exec console under Tools > Options > Network and firewall
select the specific network card to assign to the Media Server for
backups.
b.
Run the backup and observe the result.
If the issue
still occurs after performing the steps listed above, review the TechNotes in
the Related Documents Section below for additional troubleshooting
information.
Products Applied:
Backup Exec for Windows Servers 10.0, 10d (10.1), 10d (10.1) 5629, 11d (11.0), 11d (11.0) 6235, 11d (11.0) 7170, 12.0, 12.5, 9.0, 9.1
Subjects:
Backup Exec for Windows Servers
Application: Troubleshooting
Remote Agent For Windows Servers: Troubleshoot
Languages:
English (US)
Operating Systems:
Windows 2000Advanced Server, Server
Windows Server 2003
Enterprise Server
Windows Server 2008
Enterprise (x86-32bit), Standard (x86-32bit)