Volumes remain in a "Stopped" or "Missing" state when LUNs are presented from an EMC Invista solution.
Exact Error Message
ERROR: CVxDatabase::CreateGroupNode() call to DbCreateGroupNode failed.
CDdlprov: CreateGroupNodes failed. Error c1000001
LoadProvider: load failed for provider ddlprov. error = 0xc1000001
Details:
If an EMC Invista solution is used to present virtualised
storage to a Storage Foundation for Windows (SFW) 5.x solution, Disk Group
import may not correctly detect volume arrival through PNP meaning that volumes
are shown as "Stopped" or "Missing" in the Veritas Enterprise Administrator
(VEA) UI. Additionally, the Veritas Storage Agent (vxvm) may terminate if
restarted.
The above errors will be observed in the
%VMPATH%\logs\vm_vxisis.log.
Note: %VMPATH% is an environment
variable pointing to the Volume Manager installation directory.
If
this issue occurs in a clustered environment, the following symptoms can also be
seen:
SFW/HA Cluster (VCS):
The MountV resources will fail to
online because the volume will not be available for
mounting.
Microsoft Cluster Server (MSCS):
The Volume Manager
Disk Group (VMDg) resource will take 120 seconds to online, but since the
volumes will remain offline, any resource above the VMDg that requires access to
the volume (i.e. FileShare) will fault when they attempt to access the
volume.
Cause:
Using Invista changes the LUN Product ID to
Invista. There is an issue in the SFW DDLprov provider where it can not
handle the Invista ID. This results in the provider failing to
load. If this provider is not loaded, volume refreshes are not handled
automatically by SFW.
Resolution:
A private fix has been
created to allow the DDLprov provider to load properly when disks from an EMC
Invista solution are presented.
To obtain the private fix, contact
Symantec Enterprise Technical Support and reference this article during the
call. A support representative will be available to assist in troubleshooting
this issue. If it is determined that the private fix addresses the problem the
support representative will further assist in obtaining the private fix.
Note: This fix specifically addresses the problem identified above. It
has not been fully tested and should be applied in a test environment before
placing into production. If the systems are not critically impaired, it is
recommended to delay the installation of this private fix until the next
scheduled maintenance release. Before applying this private fix, systems may be
required to be upgraded to the latest code base. The support representative will
help in determining the best course of action.
Supplemental Material:| System: Ref.# | Description |
| ETrack: 1555723 | Volume Arrival issues on servers utilizing EMC Invista storage with SFW/HA 5.1 |
| ETrack: 1861896 | Storage Agent terminates due to EMC Invista devices |
Products Applied:
Storage Foundation HA for Windows 5.0, 5.0 RP1, 5.0 RP1a, 5.0 RP2, 5.1, 5.1 AP1
Storage Foundation for Windows 5.0, 5.0 RP1, 5.0 RP1a, 5.0 RP2, 5.1, 5.1 AP1
Subjects:
Storage Foundation for Windows
Application: Volume Management
Storage Foundation HA for Windows
Software: Disk Group, Dynamic Disk, Volume (Data)
Languages:
English (US)
Operating Systems:
Windows Server 2003DataCenter SP1, DataCenter SP1(IA64), DataCenter SP1(x64), DataCenter SP2, Datacenter SP2(x64), Enterprise SP1(IA64), Enterprise SP1(x64), Enterprise SP2, Enterprise SP2(x64), Enterprise ServerSP1, R2, Standard Server SP1, Standard Server SP1 (x64), Standard Server SP2, Standard Server SP2 (x64), Storage Server SP1, Storage Server SP2, Web Server SP1, Web Server SP2
Windows Server 2008
DataCenter (x64-64bit), DataCenter (x86-32bit), Enterprise (x64-64bit), Enterprise (x86-32bit), Itanium, Server Core, Standard (x64-64bit), Standard (x86-32bit)
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