Granular Recovery Technology (GRT) based backup of Exchange Database to a Backup to Disk (B2D) Folder fails with error "Final error: 0xe00084af - The directory or file was not found, or could not be accessed"
Details:
When the
backup fails with the error above, Beremote debug from the media server shows
the following during hard recovery:
5728]
09/02/08 00:03:36 JetExternalRestore(2) - ERROR::RC = -1018 - -1018 There is a
checksum error on a database page.
[5728]
09/02/08 00:03:36 Using EDB Provider for Browse/Backup.
[5728]
09/02/08 00:03:36 Logon: m_lpMAPISession->Logon returned
80004005
[5728]
09/02/08 00:03:36 OPEN DATABASE FAILED: -1018 There is a checksum error on a
database page.
[5728]
09/02/08 00:03:36 MB2_Chgdir:Logon returned e000fea9
[5728]
09/02/08 00:03:36 LP_ENV::MsgError: error 0xe00084af processing object Mailbox
Store
Cause:
This error
comes up when the job starts writing data to an IMG File and during backup, the
disk is full, so the job tries to delete an expired IMG, and this is when the
job fails. If the job has another Storage Group selected, the backup of that
storage group will run fine since the previous Storage Group backup has already
deleted an IMG to reclaim space.
Workaround: Erase
the expired IMG Media in the target Backup to Disk folder before the job
starts.
Solution:
Upgrade to
Backup Exec 12 or later, because the newer versions delete an expired IMG to
reclaim disk space prior to the start of the backup, before attempting to write
GRT data to a new IMG.
Products Applied:
Backup Exec 11d (11.0), 11d (11.0) 7170, 12.0 (Fixed), 12.5
Subjects:
Backup Exec
Agent For Exchange: Backup-Restore, Troubleshoot
Publishing Status: Kcs
Languages:
English (US)
Operating Systems:
Windows Server 2003Standard Server
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