Access denied is reported while running backups to disk, or restores from tape, of Exchange 2003 from an x64 bit media server.
Exact Error Message
Access Denied. Cannot backup directory Mailbox Store and its subdirectories.
Details:
Confirm the following before implementing the
workaround below:
- Backup
Exec is installed on an x64 bit OS
- Backup
Exec is protecting a 32 bit Exchange 2003 server
- Hotfix
4 for Backup Exec 11d 7170 has been applied to the media server and Exchange
server (file version: 11.0.7170.4)
- SGMON
output of BEREMOTE reports: BEREMOTE: REM_PROV:could not create edb provider.
(See related docs on how to run
SGMON)
Cause:
The 64 bit version
of EDBProv.dll is being copied into the (x86) Program Files instead of the 32
bit version.
Note:
The default location EDBProv.dll is
C:\Program Files (x86)\Symantec\Backup Exec.
There are two instances
of the EDBProv.dll on the media server. This only effects the one that is
located in (x86) program files.
Workaround:
1. Stop
the Backup Exec services on the x64 bit media server.
2. Rename the
EDBProv.dll located in C:\Program Files (x86)\Symantec\Backup Exec
directory
3. Copy the EDBProv.dll from the C:\Program Files\Symantec\Backup
Exec\ directory on the remote Exchange server into the directory mentioned above
on the media server.
4. Re-start the Backup Exec services on the media
server.
Permanent Fix:
This issue has been resolved
in hotfix 14 for Backup Exec version 11d 7170. See related document to obtain
this fix.
Supplemental Material:| System: Ref.# | Description |
| ETrack: 1074701 | GRT: Access denied on B2D backups or restore from tape from an x64 bit media server. |
Products Applied:
Backup Exec for Windows Servers 11d (11.0), 11d (11.0) 7170
Subjects:
Backup Exec for Windows Servers
Agent For Exchange: Backup-Restore
Languages:
English (US)
Operating Systems:
Windows Server 2003DataCenter, DataCenter (x64), DataCenter SP1(x64), Enterprise (x64), Enterprise SP1(x64), Enterprise Server, Standard Server, Standard Server(x64)
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