Document ID: 254635
http://support.veritas.com/docs/254635
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While pushing out the Remote Agent for Windows Servers 9.x, the install fails with: "Unsuccessful Backup Exec Remote Agents install."

Exact Error Message
Unsuccessful Backup Exec Remote Agents install.

Details:
Symptom:

To install the Remote Agent for Windows Servers, the push install method is the most common. For this, within VERITAS Backup Exec (tm), go to Tools | Serial Numbers and Installation... and proceed to perform a remote install of the Remote Agent to a computer on the network.

If the install fails, an error is seen as in Figure 1.

Figure 1
 

By clicking Next, the installation will be successful as in Figure 2.

Figure 2
 

During the installation, a message appears on the remote computer screen as in Figure 3.

Figure 3
 

After the installation has completed, the Backup Exec Remote Agent for Windows Servers Service appears but it will not be started. In some cases, the Remote Agent Service might even be started. However, after a reboot, the Remote Agent will not start.  

Any attempt to start the service results in the following error (Figure 4):

Figure 4
 

A successful installation of the Remote Agent would also show in add/remove programs, which in this case, it will not.


Cause:
This issue is caused because Microsoft Outlook has been installed on the remote computer, but not configured as the default mail client.

Before proceeding to the solution, remove the partial install of the Remote Agent from the remote computer by doing the following:

1.  On the remote computer, open Regedit

2.  Delete the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BackupExecAgentAccelerator

3.  Reboot the computer

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.


Solution:
There are three possible solutions:

1. Make Microsoft Outlook the default mail client and repeat the installation

    a.  On the remote computer, open Internet Explorer

    b.  Go to Tools | Internet Options | Programs tab

    c.  Click the dropdown box next to Email and select Microsoft Outlook (Figure 5)

Figure 5
 

    d.  Click OK

    e.  Repeat the push installation


2. During the push install of the Remote Agent, the install will hang for a long time at 56% as in Figure 6.

Figure 6
 

When the install reaches 56%, it also co-relates with the time that the Microsoft Outlook message appears on the remote computer (Figure 3).

Click OK to the Outlook message, and the Remote Agent install will complete successfully and work.


3. Install the Remote Agent from the command line of the remote computer by doing the following:

    a. From the remote computer, map a network drive to X:\Program Files\Veritas\Backup Exec\NT\Agents\Rant32 on the media server ("X" being the install drive)
 
    b. At the command prompt, switch to the mapped drive

    c. Type the command:  setup.exe /RANT32: -s



Products Applied:
 Backup Exec for Windows Servers 9.0, 9.0 4367, 9.0 4367 SP1, 9.0 4454, 9.0 4454 SP1, 9.1, 9.1 4691, 9.1 4691 SP1

Last Updated: September 30 2004 09:38 PM GMT
Expires on: 365 days from publish date
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Subjects:
 Backup Exec for Windows Servers
   Application: Remote Agent For Nt
   Operating System: Installation
   Priority: 01
   Remote Agent For Windows Servers: Troubleshoot

Languages:
 English (US)

Operating Systems:
Windows 2000

Advanced Server, Advanced Server SP1, Advanced Server SP2, Advanced Server SP3, Advanced Server Windows Powered, Advanced Server Windows Powered SP1, Advanced Server Windows Powered SP2, Datacenter Server, Datacenter Server SP1, Datacenter Server SP2, Datacenter Server SP3, Professional, Professional SP1, Professional SP2, Professional SP3, Server, Server SP1, Server SP2, Server SP3, Server Windows Powered, Server Windows Powered SP1, Server Windows Powered SP2

Windows NT

4.0 Server, 4.0 Server SP6a, 4.0 Workstation SP6a

Windows NT Small Business Server

2000, 4.5

Windows XP

Home 5.1, Pro 5.1, Pro 5.1 64-bit, Pro 5.1 SP1