Symptom:
To install the Remote Agent for Windows
Servers, the push install method is the most common. For this, within VERITAS
Backup Exec (tm), go to
Tools | Serial Numbers and Installation... and
proceed to perform a remote install of the Remote Agent to a computer on the
network.
If the install fails, an error is seen as in Figure
1.
Figure
1
By
clicking
Next, the installation will be successful as in Figure
2.
Figure
2
During the installation, a message appears on the remote computer screen
as in Figure 3.
Figure
3
After
the installation has completed, the Backup Exec Remote Agent for Windows Servers
Service appears but it will not be started. In some cases, the Remote Agent
Service might even be started. However, after a reboot, the Remote Agent will
not start.
Any attempt to start the service results in the
following error (Figure 4):
Figure
4
A
successful installation of the Remote Agent would also show in add/remove
programs, which in this case, it will not.
Cause:
This issue is
caused because Microsoft Outlook has been installed on the remote computer, but
not configured as the default mail client.
Before proceeding to the
solution, remove the partial install of the Remote Agent from the remote
computer by doing the following:
1. On the remote computer, open
Regedit2. Delete the key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BackupExecAgentAccelerator3. Reboot
the computer
Warning: Incorrect use of the Windows registry editor
may prevent the operating system from functioning properly. Great care should be
taken when making changes to a Windows registry. Registry modifications should
only be carried-out by persons experienced in the use of the registry editor
application. It is recommended that a complete backup of the registry and
workstation be made prior to making any registry
changes.
Solution:
There are three possible solutions:
1.
Make Microsoft Outlook the default mail client and repeat the
installation
a. On the remote computer, open
Internet Explorer
b. Go to
Tools |
Internet Options | Programs tab
c. Click the dropdown box next to
Email and select
Microsoft
Outlook (Figure 5)
Figure
5
d. Click
OK
e. Repeat the push installation
2. During the push install of
the Remote Agent, the install will hang for a long time at 56% as in Figure
6.
Figure
6
When
the install reaches 56%, it also co-relates with the time that the Microsoft
Outlook message appears on the remote computer (Figure 3).
Click
OK
to the Outlook message, and the Remote Agent install will complete
successfully and work.
3. Install the Remote Agent from the command
line of the remote computer by doing the following:
a.
From the remote computer, map a network drive to
X:\Program
Files\Veritas\Backup Exec\NT\Agents\Rant32 on the media server ("X" being
the install drive)
b. At the command prompt, switch
to the mapped drive
c. Type the
command:
setup.exe /RANT32: -s